새로운 글
새로운 덧글

자유롭게 질의 및 응답을 할 수 있는 게시판이며 어느 누구도 답변을 달아야만 하는 의무는 없습니다. 
  • 제품설치/등록/제품 오류 문의: 설치/등록 Q&A 이용 (제품 구매 고객 한정)

본 게시판은 개발자들이 자유롭게 질문과 답변을 공유하는 게시판입니다.
* 따라서 최대한 정중하게 질문을 올려 주세요.
* 질문을 상세히 작성해 주실 수록 좋은 답변이 올라 옵니다.
* 다른 분들도 참고할 수 있도록 결과 댓글 필수(또는 감사 댓글)
(결과 댓글을 달지 않는 경우 다음 질문에 대한 답변이 달리지 않는 불이익이 있을 수 있습니다.)
-----------------------------------------------------------------------------------------------

 

* 환경

- 델파이 10.3

- 오라클 클라이언트 9i

- BDE 10.3 Rio


이번에 델파이 10.3을 설치하면서, 델파이 10.3을 지원하는 BDE 10.3 Rio를 설치하게 되었습니다.

기존의 BDE 버전은 오래된 5.01 버전입니다.

bde_version.png

 

 

 

 

 

 

 

 

기존의 버전을 삭제한후, 새로운 BDE 10.3 Rio를 설치했을 경우, 오라클 클라이언트를 인식하지 못하게 됩니다...

 

< BDE 5.01 버전에서의 Administrator 화면 > < BDE 10.3 Rio 버전에서의 Administrator 화면 >
bde_normal.png bde_weird.png

 

 

BDE 10.3 Rio 설치 후, Oracle client가 제대로 잡히지 않은 상태로, 델파이 10.3로 마이그레이션한 프로그램을 실행시켰을 경우 아래의 오류 메시지가 발생합니다.

error_1.png

error_2.png

질문을 드리자면...

 

1) WIN10 환경에서 Oracle client 9i, 델파이 10.3를 그대로 두고 위의 상황을 해결하려면 어떻게 해야하나요?

 

2) 이전 버전인 BDE 5.0.1을 그대로 두었을 경우 델파이 프로그램을 실행하는데 오류는 없습니다.

    하지만, 델파이 10.3을 사용하는데 계속 문제가 없을지는 모르겠는데..괜찮을까요?

 

 

 

 

 



광고 모듈이 설치되어 있지 않아 실행을 중단합니다..