자유롭게 질의 및 응답을 할 수 있는 게시판입니다. 개발자 여러분의 답변이 큰 도움이 됩니다. 
  • 제품설치/등록 오류 문의: 설치/등록 Q&A 이용 (제품 구매 고객 한정)

RAD 서버 배포 오류

2021.08.17 14:02

케이피 조회 수:875

본 게시판 제품 구매 고객사에 대한 설치 및 등록 관련 문의 게시판입니다.
* 프로페셔널, 커뮤니티 에디션은 이곳에서 기술지원이 제공되지 않으므로
* http://quality.embarcadero.com 또는 http://www.embarcadero.com/support를 이용하세요.
* 개발 관련 문의 또는 버그 문의의 경우 개발자Q&A를 이용해 주시기 바랍니다.

또한 질문을 등록하기에 앞서서 검색을 해보시기 바랍니다.
* 대부분의 답이 설치/등록가이드 또는 개발자 Q&A에 이미 있습니다.
* 엠바카데로 제품이 아닌 외부 컴포넌트는 해당 제조사에 문의를 하셔야 하며
* 코딩 관련 문의는 개발자Q&A 게시판을 이용하시기 바랍니다.
-----------------------------------------------------------------------------------------------
 

본 게시판은 개발자들이 자유롭게 질문과 답변을 공유하는 게시판입니다.
* 따라서 최대한 정중하게 질문을 올려 주세요.
* 질문을 상세히 작성해 주실 수록 좋은 답변이 올라 옵니다.
* 다른 분들도 참고할 수 있도록 결과 댓글 필수(또는 감사 댓글)
(결과 댓글을 달지 않는 경우 다음 질문에 대한 답변이 달리지 않는 불이익이 있을 수 있습니다.)
-----------------------------------------------------------------------------------------------
안녕하세요

바쁘신데 송구스럽습니다......

내 혼자 할려고 마음먹었으나 도저히 진척이 없어서 글 올립니다.

 

REST API를 EMS 패키지로 구현해 서버에 배포테스트를 하고 있습니다.

 

험프리님이 올려놓으신 

[RAD서버] EMS 패키지 프로젝트 시작하기

를 따라하면 RAD 서버  EMS 를 테스트 하고 있습니다.

 

개발(PC)에서는 현재 실행이 되는데.... 윈도우 2016 서버에서는 오류가 계속 나고 있습니다.

 

서버에 설치한 순서 말씁드리곘습니다.

1.인테베이스 설치 

엠바카데로 홈페이지 -무료도구 -interbase 개발자 에디션 에서 다운받았습니다.

설치시 서버/클라이언트 로 설치했구요... 등록키는 RAD Server Multi-Site License 번호를 등록했습니다.

인터베이스 설치를  10번넘게 하나보니 인터베이스 매니저에 실행이 됨니다.

내가 설치한 인테베이스(개발자) 가 맞는지 잘모르겠습니다.

개발 PC에서는 실행하면 EMS 설정 창이 나와서 작동 잘되는데 서버에서는 안됨니다.

 

2. [RAD서버] EMS 패키지 프로젝트 시작하기

순서대로 다 진행했습니다.

그런데 서버에서 실행시 설정(구성)창이 나오지 않았습니다.

 

C:\EMSServer\EMSDevServer 폴더에는  개발(pc) C:\Program Files (x86)\Embarcadero\Studio\21.0\bin64 

폴더의 모두 복사했습니다.

 

C:\EMSServer\EnvFile 폴더에도 똑같이 복사했구요  개발(PC)실행파일에서  EMSSERVER.IB , emsserver.ini 복사 했습니다.

 

--아래설정은 서버에 경로가 없어서 개발(pc)의 경로를 똑같이 복사해서 설정했습니다.

emsserver.ini 설정

[Console.Paths.Dev]

ResourcesFiles =C:\Program Files (x86)\Embarcadero\Studio\21.0\ObjRepos\en\EMS

 

현재 여러 오류가 계속 나고 있습니다. 

오류 메세지는 여러가지가 발생해서 일단 마지막오류 메세지와 사진으로 올리겠습니다.

서버에 설정한파일은 압축해서 올리겠습니다.( EMSDevServer 폴더의 BPL.DLL 은 용량이 커서 삭제했습니다.)

 

염치없이 도움부탁드립니다.

감사합니다.

 

----사양

서버 : 윈도우 서버 2016 / 방화벽해제/ 3050,3051,8080,8081 포트 개방

개발(PC) : 델파이 시드니 10.4 / 윈도우 10 Pro

 

 

123.jpg

 

 

 

번호 제목 글쓴이 날짜 조회 수
공지 [프로그래밍 강의] 2021.6~2021.12 관리자 2015.01.22 13251
공지 유용한 관련 사이트 관리자2 2014.03.20 51833
공지 본 게시판은 개발자 여러분들의 질문과 답변을 공유하는 공간입니다. 관리자 2012.01.10 92095
3282 델파이 10.4.1 환경에서 IOS Device 14.4 디버깅 관련 문의 [2] 2an 2021.02.24 607
3281 [공유] TServerSocket, TClientSocket은 어떻게 등록하나요? file Humphery 2015.03.24 2510
3280 델파이 10.3.3에서 컴파일된 apk 안드로이드 11에서 로드 안되는 현상입니다. [7] 돌떵이이11 2021.01.28 1176
3279 델파이 C/S프로그램을 웹으로 전환해서 보여주는 방법 연일하 2015.10.28 2238
3278 [10.4 시드니 신기능 Q&A] Thinfinity VirtualUI(데스크탑 앱을 웹브라우저에서 실행 솔루션)의 한글 입력이 매끄럽지 못합니다. 험프리 2020.06.10 860
3277 Timage Picture.data : Access Violation 문의 [1] file 유경아빠 2021.08.31 843
3276 JSON 파라메타 한글 문제 [2] file 케이피 2021.08.26 999
3275 델파이(안드로이드) , cubrid 연결 문의. [3] Hoony 2021.08.09 927
3274 자동차 인식 방법에 대한 질문입니다. [4] file 거북선생 2021.08.25 938
3273 델파이 10.4 patch하니 실행이 안됩니다. [7] file 갈굼정미 2021.08.26 875
3272 UC-win/Road에서 앞차와 거리를 측정하려고 합니다. [1] jhjh 2021.08.25 1672
3271 [질문] SMS 문자보내기 창으로 이동하는 방법 [1] 화현 2021.07.18 1022
3270 10.4 버젼 [1] 시작.. 2021.08.17 869
3269 delphi 10.2 버전에서 크로미움으로 Chrome 브라우저를 사용중인데..mp4 같은 동영상이 실행이 안됩니다. [1] 미스터리 2021.07.11 1174
3268 [질문] 이미지를 datasnap을 사용하여 서버로 전송밥법 [2] 화현 2021.08.08 893
3267 데이타베이스 파이어버드인데 REST API RAD서버 구축 가능할까요? [4] 케이피 2021.08.15 1053
» RAD 서버 배포 오류 [2] file 케이피 2021.08.17 875
3265 (팁) TRESTRequest Post방식 파일업로드와 함께 텍스트 변수 전송 10.4에서만 성공 미스터몽키 2021.08.18 2459
3264 RAD 서버 운영환경에 설치중 오류 [2] file 노란바나나 2019.10.30 982
3263 Multi-Device Application 질문입니다. [2] UK'S 2021.08.12 881